Ecamm Live Support

Ecamm Live System Requirements



  • Ecamm Live requires macOS 10.12 or newer (including macOS 10.14 Mojave) and a Mac with a microphone.

  • You'll also need an internet connection fast enough to stream live video. At least a 1 Mbps upload speed is required. 4 Mbps is required for the "Use High Quality" mode.

  • A Mac with hardware-accelerated video encoding is required. This includes most Macs manufactured after 2010.

  • For best results, use a Mac with a Metal compatible GPU. This includes modes Macs manufactured during or after 2012.